You are here

Drupal主题: 此版本与Drupal 7.x不兼容应当予以替换。

新建了一个Drupal主题,拿drupal6的稍微做了一些修改,没有想到出现这样的提示: 此版本与Drupal 7.x不兼容应当予以替换。

 
This version is not compatible with Drupal 7.x and should be replaced.
 
把info文件中的 设置为7.x core = 7.x
去掉了engine = phptemplate
清空缓存还是不行.
 
后来通过搜索找到了一篇文章: http://drupal.org/node/785714,同样的问题.
原因是因为在Drupal7中,content区域是必须声明的.
regions[content] = Content
 
加上这一句后,主题就可以启用了.Drupal7的主题info文件,才发现里面也有不少的变更.
 

Drupal版本: